// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?im)^([\da-z-]+?)(?:[-/](\d+))?$").unwrap();
let string = "ThePixies1996
7ThePixies
The-Pixies
The-Pixies-1234567
The-Pixies/1234567";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}