use strict;
my $str = 'ec2-54-189-171-120.us-east-1.compute.amazonaws.com
ec2-35-158-116-105.us-east-2.compute.amazonaws.com
ec2-13-210-58-232.us-west-1.compute.amazonaws.com
ec2-54-202-130-232.us-west-2.compute.amazonaws.com
ec2-52-40-225-119.af-south-1.compute.amazonaws.com
ec2-54-244-14-137.ap-east-1.compute.amazonaws.com
ec2-54-188-91-145.ap-south-1.compute.amazonaws.com
ec2-16-221-167-247.ap-northeast-1.compute.amazonaws.com
ec2-34-221-167-247.ap-northeast-2.compute.amazonaws.com
ec2-34-221-167-247.ap-northeast-3.compute.amazonaws.com
ec2-34-221-167-247.ap-southeast-1.compute.amazonaws.com
ec2-34-221-167-247.ap-southeast-2.compute.amazonaws.com
ec2-34-221-167-247.ap-southeast-3.compute.amazonaws.com
ec2-34-221-167-247.ca-central-1.compute.amazonaws.com
ec2-34-221-167-247.eu-central-1.compute.amazonaws.com
ec2-34-221-167-247.eu-west-1.compute.amazonaws.com
ec2-34-221-167-247.eu-west-2.compute.amazonaws.com
ec2-34-219-81-114.eu-west-3.compute.amazonaws.com
ec2-52-35-119-24.eu-south-1.compute.amazonaws.com
ec2-35-160-82-97.eu-north-1.compute.amazonaws.com
ec2-34-223-253-69.me-south-1.compute.amazonaws.com
ec2-34-216-36-192.sa-east-1.compute.amazonaws.com
';
my $regex = qr/ec2-(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})(?:-(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})){3}\.(?:eu|us|af|ap|ca|me|sa)-(?:west|central|south|north|(?:south|north)?east)-[1-9]{1,1}\.compute\.amazonaws\.com/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}