// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)ec2-(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})(?:-(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})){3}\.(?:eu|us|af|ap|ca|me|sa)-(?:west|central|south|north|(?:south|north)?east)-[1-9]{1,1}\.compute\.amazonaws\.com").unwrap();
let string = "ec2-54-189-171-120.us-east-1.compute.amazonaws.com
ec2-35-158-116-105.us-east-2.compute.amazonaws.com
ec2-13-210-58-232.us-west-1.compute.amazonaws.com
ec2-54-202-130-232.us-west-2.compute.amazonaws.com
ec2-52-40-225-119.af-south-1.compute.amazonaws.com
ec2-54-244-14-137.ap-east-1.compute.amazonaws.com
ec2-54-188-91-145.ap-south-1.compute.amazonaws.com
ec2-16-221-167-247.ap-northeast-1.compute.amazonaws.com
ec2-34-221-167-247.ap-northeast-2.compute.amazonaws.com
ec2-34-221-167-247.ap-northeast-3.compute.amazonaws.com
ec2-34-221-167-247.ap-southeast-1.compute.amazonaws.com
ec2-34-221-167-247.ap-southeast-2.compute.amazonaws.com
ec2-34-221-167-247.ap-southeast-3.compute.amazonaws.com
ec2-34-221-167-247.ca-central-1.compute.amazonaws.com
ec2-34-221-167-247.eu-central-1.compute.amazonaws.com
ec2-34-221-167-247.eu-west-1.compute.amazonaws.com
ec2-34-221-167-247.eu-west-2.compute.amazonaws.com
ec2-34-219-81-114.eu-west-3.compute.amazonaws.com
ec2-52-35-119-24.eu-south-1.compute.amazonaws.com
ec2-35-160-82-97.eu-north-1.compute.amazonaws.com
ec2-34-223-253-69.me-south-1.compute.amazonaws.com
ec2-34-216-36-192.sa-east-1.compute.amazonaws.com
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}