# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"ec2-(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})(?:-(?:25[0-5]|2[0-4]\d|[0-1]?\d{1,2})){3}\.(?:eu|us|af|ap|ca|me|sa)-(?:west|central|south|north|(?:south|north)?east)-[1-9]{1,1}\.compute\.amazonaws\.com"
test_str = ("ec2-54-189-171-120.us-east-1.compute.amazonaws.com\n"
"ec2-35-158-116-105.us-east-2.compute.amazonaws.com\n"
"ec2-13-210-58-232.us-west-1.compute.amazonaws.com\n"
"ec2-54-202-130-232.us-west-2.compute.amazonaws.com\n"
"ec2-52-40-225-119.af-south-1.compute.amazonaws.com\n"
"ec2-54-244-14-137.ap-east-1.compute.amazonaws.com\n"
"ec2-54-188-91-145.ap-south-1.compute.amazonaws.com\n"
"ec2-16-221-167-247.ap-northeast-1.compute.amazonaws.com\n"
"ec2-34-221-167-247.ap-northeast-2.compute.amazonaws.com\n"
"ec2-34-221-167-247.ap-northeast-3.compute.amazonaws.com\n"
"ec2-34-221-167-247.ap-southeast-1.compute.amazonaws.com\n"
"ec2-34-221-167-247.ap-southeast-2.compute.amazonaws.com\n"
"ec2-34-221-167-247.ap-southeast-3.compute.amazonaws.com\n"
"ec2-34-221-167-247.ca-central-1.compute.amazonaws.com\n"
"ec2-34-221-167-247.eu-central-1.compute.amazonaws.com\n"
"ec2-34-221-167-247.eu-west-1.compute.amazonaws.com\n"
"ec2-34-221-167-247.eu-west-2.compute.amazonaws.com\n"
"ec2-34-219-81-114.eu-west-3.compute.amazonaws.com\n"
"ec2-52-35-119-24.eu-south-1.compute.amazonaws.com\n"
"ec2-35-160-82-97.eu-north-1.compute.amazonaws.com\n"
"ec2-34-223-253-69.me-south-1.compute.amazonaws.com\n"
"ec2-34-216-36-192.sa-east-1.compute.amazonaws.com\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.