using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\d+\.\h+\K[^\n+-]*[^\s+-](?=\h*[+-])";
string input = @"1. Medium Size +CA $33.00
2. Small Size -CA $4.00
3. Small Size-CA $4.00
4. Small Size CA $4.00";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}