import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\d+\\.\\h+\\K[^\\n+-]*[^\\s+-](?=\\h*[+-])";
final String string = "1. Medium Size +CA $33.00\n"
+ "2. Small Size -CA $4.00\n"
+ "3. Small Size-CA $4.00\n\n"
+ "4. Small Size CA $4.00";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}