#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)\b(?:(?:f|ht)tps?:\/\/)[-\w+&@#\/%?=~|!:,.;]*[-\w+&@#\/%=~|]"
Local $sString = "https://www.example.com" & @CRLF & _
"http://www.example.com" & @CRLF & _
"ftps://www.example.com" & @CRLF & _
"ftp://www.example.com" & @CRLF & _
"https://example.com" & @CRLF & _
"http://example.com" & @CRLF & _
"ftps://example.com" & @CRLF & _
"ftp://example.com" & @CRLF & _
"www.example.com" & @CRLF & _
"https://www.example.com?u=123&txt=abc#anchor" & @CRLF & _
"http://www.example.com#:~:text=hightlightfromhere,tohere" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")