// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)\b(?:(?:f|ht)tps?:\/\/)[-\w+&@#\/%?=~|!:,.;]*[-\w+&@#\/%=~|]").unwrap();
let string = "https://www.example.com
http://www.example.com
ftps://www.example.com
ftp://www.example.com
https://example.com
http://example.com
ftps://example.com
ftp://example.com
www.example.com
https://www.example.com?u=123&txt=abc#anchor
http://www.example.com#:~:text=hightlightfromhere,tohere
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}