import re
regex = re.compile(r"\b(?:(?:f|ht)tps?:\/\/)[-\w+&@#\/%?=~|!:,.;]*[-\w+&@#\/%=~|]", flags=re.IGNORECASE)
test_str = ("https://www.example.com\n"
"http://www.example.com\n"
"ftps://www.example.com\n"
"ftp://www.example.com\n"
"https://example.com\n"
"http://example.com\n"
"ftps://example.com\n"
"ftp://example.com\n"
"www.example.com\n"
"https://www.example.com?u=123&txt=abc#anchor\n"
"http://www.example.com#:~:text=hightlightfromhere,tohere\n\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")