$re = '/(?<=)([.0-9]+)/m';
$str = 'Refined Sunflowerseed Oil 136,000 2.26 133,000 -9.33 150,000 45.20 93,667';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);