#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "(?m)(?i)^(?!((<\/|<)(h[1-6]|ul|li|script|blockquote)(\s.+)*>))(.+)(?!(<(\/\3)>))$"
Local $sString = "<h2>Lorem ipsum dolor sit amet, consectetur adipiscing elit</h2>" & @CRLF & _
"" & @CRLF & _
"Vivamus vel tempor turpis, <strong>non rutrum quam</strong>. Suspendisse ac rhoncus felis, eget porta lectus. " & @CRLF & _
"" & @CRLF & _
"Nam vulputate sapien risus, vel vehicula mi volutpat sed. " & @CRLF & _
"" & @CRLF & _
"<ul>" & @CRLF & _
"<li>Sed feugiat nibh at nisl eleifend scelerisque.</li>" & @CRLF & _
"<li>Aliquam non maximus ipsum. Aliquam erat volutpat.</li>" & @CRLF & _
"</ul>" & @CRLF & _
"" & @CRLF & _
"<h3>Praesent eget diam sit amet leo vehicula sagittis at quis tortor</h3>" & @CRLF & _
"" & @CRLF & _
"Nunc nec sem ac nunc tincidunt aliquam ut nec dolor. Nulla facilisi." & @CRLF & _
"" & @CRLF & _
"<img alt="xxxx" src="xxx.png" class="xxxxx"/> " & @CRLF & _
"" & @CRLF & _
"<caption><i>ccccc</i></caption> " & @CRLF & _
"" & @CRLF & _
"<img alt="xxxx" src="xxx.png" class="xxxxx"/> " & @CRLF & _
"" & @CRLF & _
"<i>ccccc</i>" & @CRLF & _
"" & @CRLF & _
"<strong>Nunc nec sem ac nunc tincidunt aliquam ut nec dolor. Nulla facilisi.</strong>" & @CRLF & _
"" & @CRLF & _
"Vivamus vel tempor turpis, <strong>non rutrum quam</strong>. Suspendisse ac rhoncus felis, eget porta lectus." & @CRLF & _
"" & @CRLF & _
"Nunc nec" & @CRLF & _
"Nunc nec" & @CRLF & _
"Nunc nec" & @CRLF & _
"" & @CRLF & _
"<blockquote class="twitter-tweet" data-lang="en"><p lang="en" dir="ltr">Vivamus vel tempor turpis <a href=""></a></p>— xxxxx (@xxxxxx) <a href="https://twitter.com/xxxx/status/x?ref_src=x">February 15, 2019</a></blockquote>" & @CRLF & _
"" & @CRLF & _
"<script async src="" charset="utf-8"></script>"
Local $sSubst = "<p>$5</p>"
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)