using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"д(ом|\.)\s*\K\d[^,|\s|;]*";
string input = @"Большой Факельный переулок, дом 23
улица Госпитальный Вал, дом 3 строение 2
микрорайон «В», дом 26; 26 (строение 1)
Средняя Калитниковская улица, дом 9/11, строение 1
Жулебинский бульвар, дом 28 корпус 2
ш. Волоколамское, д. 14 с, стр. 1
Ружейный пер., 8";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}