$re = '/д(ом|\.)\s*\K\d[^,|\s|;]*/m';
$str = 'Большой Факельный переулок, дом 23
улица Госпитальный Вал, дом 3 строение 2
микрорайон «В», дом 26; 26 (строение 1)
Средняя Калитниковская улица, дом 9/11, строение 1
Жулебинский бульвар, дом 28 корпус 2
ш. Волоколамское, д. 14 с, стр. 1
Ружейный пер., 8';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);