import Foundation
let pattern = #"д(ом|\.)\s*\K\d[^,|\s|;]*"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
Большой Факельный переулок, дом 23
улица Госпитальный Вал, дом 3 строение 2
микрорайон «В», дом 26; 26 (строение 1)
Средняя Калитниковская улица, дом 9/11, строение 1
Жулебинский бульвар, дом 28 корпус 2
ш. Волоколамское, д. 14 с, стр. 1
Ружейный пер., 8
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)