package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?i)(?:a\/c|account)\s*no\.?\s+(\w+)`)
var str = `bank of india account statement name abcd account no. 123456 account type savings account
statement for a/c no 11111111 between 16-09-2019 and 16-03-2020
shyam alaspure period 01-12-2019 to 29-02-2020 cust.reln.no XXXXXXXX account no 9XXX99999`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}