import re
regex = re.compile(r"(?i)(?:a\/c|account)\s*no\.?\s+(\w+)", flags=re.MULTILINE)
test_str = ("bank of india account statement name abcd account no. 123456 account type savings account\n\n"
"statement for a/c no 11111111 between 16-09-2019 and 16-03-2020\n\n"
"shyam alaspure period 01-12-2019 to 29-02-2020 cust.reln.no XXXXXXXX account no 9XXX99999")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")