re = /(?i)(?:a\/c|account)\s*no\.?\s+(\w+)/m
str = 'bank of india account statement name abcd account no. 123456 account type savings account
statement for a/c no 11111111 between 16-09-2019 and 16-03-2020
shyam alaspure period 01-12-2019 to 29-02-2020 cust.reln.no XXXXXXXX account no 9XXX99999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end