#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<(\w*[dD]ate\w*)>\d{13}<\/\1>"
Local $sString = "<dateCreated>1619155581543</dateCreated>" & @CRLF & _
"<dispatchDate>1619478000000</dispatchDate>" & @CRLF & _
"<deliveryDate>1619564400000</deliveryDate>" & @CRLF & _
"<thirteendigits>1619564400000</thirteendigits>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")