re = /<(\w*[dD]ate\w*)>\d{13}<\/\1>/m
str = '<dateCreated>1619155581543</dateCreated>
<dispatchDate>1619478000000</dispatchDate>
<deliveryDate>1619564400000</deliveryDate>
<thirteendigits>1619564400000</thirteendigits>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end