import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\w*[dD]ate\\w*)>\\d{13}<\\/\\1>";
final String string = "<dateCreated>1619155581543</dateCreated>\n"
+ "<dispatchDate>1619478000000</dispatchDate>\n"
+ "<deliveryDate>1619564400000</deliveryDate>\n"
+ "<thirteendigits>1619564400000</thirteendigits>";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}