import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\b\\w{4,}\\b)(?=(.*?\\1){4,})";
final String string = "hello, bonjour bonjour, ceci est un test dans lequel bonjour est écrit cinq fois et test seulement quatre fois, bonjour test, bonjour test";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}