using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<![abc]) # No ""a"", ""b"", ""c"" allowed immediately on the left
(?=(?:[bc]*a){3}) # At least three ""a""s
(?=(?:[ac]*b){3}) # At least three ""b""s
(?: # Either
(?=[ab]*(?![abc])) # only ""a"" or ""b""s allowed until a location not followed with ""a"", ""b"" or ""c""
| # or
(?=(?:[ab]*c){3}) # At least three ""c""s
)
[abc]+ # Match and consume one or more ""a"", ""b"" or ""c"" chars";
string input = @"Examples for valid sequences:
aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
Examples for invalid sequences (as a whole):
aaabbbc
aabbb
abbccc
abcabca";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}