$re = '/(?<![abc]) # No "a", "b", "c" allowed immediately on the left
(?=(?:[bc]*a){3}) # At least three "a"s
(?=(?:[ac]*b){3}) # At least three "b"s
(?: # Either
(?=[ab]*(?![abc])) # only "a" or "b"s allowed until a location not followed with "a", "b" or "c"
| # or
(?=(?:[ab]*c){3}) # At least three "c"s
)
[abc]+ # Match and consume one or more "a", "b" or "c" chars/mx';
$str = 'Examples for valid sequences:
aaabbb
ababab
aaabbbccc
abcabcabc
ababcabcc
Examples for invalid sequences (as a whole):
aaabbbc
aabbb
abbccc
abcabca';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);