#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*(?:\.jsx?|\.scss)$).*$"
Local $sString = "abc.js" & @CRLF & _
"xyz.jsx" & @CRLF & _
"ddd.scss" & @CRLF & _
"abc.jsa" & @CRLF & _
"xyz.jsxa" & @CRLF & _
"ddd.scssd"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")