re = /^(?!.*(?:\.jsx?|\.scss)$).*$/m
str = 'abc.js
xyz.jsx
ddd.scss
abc.jsa
xyz.jsxa
ddd.scssd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end