$re = '/^(?!.*(?:\.jsx?|\.scss)$).*$/m';
$str = 'abc.js
xyz.jsx
ddd.scss
abc.jsa
xyz.jsxa
ddd.scssd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);