const regex = /<\s*(\w+\b)(?:(?!<\s*\/\s*\1\b)[\s\S])*<\s*\/\s*\1\s*>|\S+/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<\\s*(\\w+\\b)(?:(?!<\\s*\\\/\\s*\\1\\b)[\\s\\S])*<\\s*\\\/\\s*\\1\\s*>|\\S+', 'g')
const str = `this is a sample <a href="http://aaa.com">link</a> and a sample <span>sdfsdfsdf</span> <img src="http://abc.com/a.png"> <br />
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}