import re
regex = re.compile(r"<\s*(\w+\b)(?:(?!<\s*\/\s*\1\b)[\s\S])*<\s*\/\s*\1\s*>|\S+")
test_str = ("this is a sample <a href=\"http://aaa.com\">link</a> and a sample <span>sdfsdfsdf</span> <img src=\"http://abc.com/a.png\"> <br />\n")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")