$re = '/<\s*(\w+\b)(?:(?!<\s*\/\s*\1\b)[\s\S])*<\s*\/\s*\1\s*>|\S+/';
$str = 'this is a sample <a href="http://aaa.com">link</a> and a sample <span>sdfsdfsdf</span> <img src="http://abc.com/a.png"> <br />
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);