package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\[\b([^\][]+)\b]`)
var str = `[me]: http://example.com
[her]: http://somewhere.com
[1]: http://nhs.net
[2]: http://test.com
[google it]: http://google.com`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}