import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\[\\b([^\\][]+)\\b]";
final String string = "[me]: http://example.com\n"
+ "[her]: http://somewhere.com\n"
+ "[1]: http://nhs.net\n"
+ "[2]: http://test.com\n"
+ "[google it]: http://google.com";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}