re = /\[\b([^\][]+)\b]/
str = '[me]: http://example.com
[her]: http://somewhere.com
[1]: http://nhs.net
[2]: http://test.com
[google it]: http://google.com'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end