using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"item\d+";
string input = @"item1, item2 item3 item4 , item5";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}