$re = '/item\d+/m';
$str = 'item1, item2 item3 item4 , item5';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);