package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)item\d+`)
var str = `item1, item2 item3 item4 , item5`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}