import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=^\\#\\[\\d{2}\\])\\S*";
final String string = "?[A7]DA<DA-SG\n"
+ "'[G7]G%SD\\$DF\n"
+ "#[27]F:./4FFF\n"
+ "?[P9]W3_2SS_F\n"
+ "'[90]GA\\\\WTER";
final String subst = "something_else";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
// The substituted value will be contained in the result variable
final String result = matcher.replaceAll(subst);
System.out.println("Substitution result: " + result);
}
}