re = /(?<=^\#\[\d{2}\])\S*/m
str = '?[A7]DA<DA-SG
\'[G7]G%SD\\$DF
#[27]F:./4FFF
?[P9]W3_2SS_F
\'[90]GA\\\\WTER'
subst = 'something_else'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result