import Foundation
let pattern = ##"(?<=^\#\[\d{2}\])\S*"##
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
?[A7]DA<DA-SG
'[G7]G%SD\$DF
#[27]F:./4FFF
?[P9]W3_2SS_F
'[90]GA\\WTER
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"something_else"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)