import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\.?(?!-)\\d+(?:\\.\\d{1,2})?$";
final String string = "123.12\n"
+ "2\n"
+ "56754\n"
+ "92929292929292.12\n"
+ "0.21\n"
+ "3.1\n"
+ ".90\n\n"
+ "12.12dd\n"
+ "2.23332\n"
+ "e666.76\n"
+ "-1.23\n"
+ "-54.3242\n"
+ "3.98A\n"
+ "56B\n"
+ "BBB.12C\n"
+ "14.23.56\n"
+ "1..45";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}