re = /^\.?(?!-)\d+(?:\.\d{1,2})?$/m
str = '123.12
2
56754
92929292929292.12
0.21
3.1
.90
12.12dd
2.23332
e666.76
-1.23
-54.3242
3.98A
56B
BBB.12C
14.23.56
1..45'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end