$re = '/(?<=[ ;|,:]|^)([A-Z\.\-a-z1-9]+@[A-Za-z1-9]+?\.[A-Za-z1-9\.]+?)(?=[ ;|,:]|$)/m';
$str = 'someo.one@asds.com ; someo.one@asds; someo.one@asds.co.uk|som123@oone.fr , ugabuga@12.gg';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);