re = /(?<=[ ;|,:]|^)([A-Z\.\-a-z1-9]+@[A-Za-z1-9]+?\.[A-Za-z1-9\.]+?)(?=[ ;|,:]|$)/m
str = 'someo.one@asds.com ; someo.one@asds; someo.one@asds.co.uk|som123@oone.fr , ugabuga@12.gg'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end