import Foundation
let pattern = #"(?<=[ ;|,:]|^)([A-Z\.\-a-z1-9]+@[A-Za-z1-9]+?\.[A-Za-z1-9\.]+?)(?=[ ;|,:]|$)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"someo.one@asds.com ; someo.one@asds; someo.one@asds.co.uk|som123@oone.fr , ugabuga@12.gg"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)