using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @".+{x\=([0-9\.]+)\s*y\=([0-9\.]+).+";
string substitution = @"($1, $2)";
string input = @"0x0000023646b21750 {x=0.74999899999999997 y=0.91666399999999992 index=69 ...}";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}