use strict;
my $str = '0x0000023646b21750 {x=0.74999899999999997 y=0.91666399999999992 index=69 ...}';
my $regex = qr/.+{x\=([0-9\.]+)\s*y\=([0-9\.]+).+/mp;
my $subst = '($1, $2)';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";