# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r".+{x\=([0-9\.]+)\s*y\=([0-9\.]+).+"
test_str = "0x0000023646b21750 {x=0.74999899999999997 y=0.91666399999999992 index=69 ...}"
subst = "($1, $2)"
# You can manually specify the number of replacements by changing the 4th argument
result = re.sub(regex, subst, test_str, 0, re.MULTILINE)
if result:
print (result)
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.