#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\-?(?:(?:\w+\.\^\(.*?\)|[\w\.\^]+|\(?\([^\(\)]+\)\)?)(?:[*/](?:(?!\-)|\-))?\([^\(\)]+\)|\([^\(\)]+\)(?:[*/](?:(?!\-)|\-))?(?:\w+\.\^\(.*?\)|[\w\.\^]+|\(?\([^\(\)]+\)\)?))"
Local $sString = "(sdf^sdf*(-sd.f*-(23^3s)))*sdf" & @CRLF & _
"-(2.32^23)*-(df.df^78)+dfd(sfsf)" & @CRLF & _
"-df.d(sfs.f^sdf+323)/-13+sfdfsdf" & @CRLF & _
"(dfd^23sdf)-(234^dfd)" & @CRLF & _
"(dfd^23sdf)-(2.34^d.fd)*-(x-3)"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")