$re = '~\-?(?:(?:\w+\.\^\(.*?\)|[\w\.\^]+|\(?\([^\(\)]+\)\)?)(?:[*/](?:(?!\-)|\-))?\([^\(\)]+\)|\([^\(\)]+\)(?:[*/](?:(?!\-)|\-))?(?:\w+\.\^\(.*?\)|[\w\.\^]+|\(?\([^\(\)]+\)\)?))~';
$str = '(sdf^sdf*(-sd.f*-(23^3s)))*sdf
-(2.32^23)*-(df.df^78)+dfd(sfsf)
-df.d(sfs.f^sdf+323)/-13+sfdfsdf
(dfd^23sdf)-(234^dfd)
(dfd^23sdf)-(2.34^d.fd)*-(x-3)';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);