const regex = new RegExp('\\-?(?:(?:\\w+\\.\\^\\(.*?\\)|[\\w\\.\\^]+|\\(?\\([^\\(\\)]+\\)\\)?)(?:[*/](?:(?!\\-)|\\-))?\\([^\\(\\)]+\\)|\\([^\\(\\)]+\\)(?:[*/](?:(?!\\-)|\\-))?(?:\\w+\\.\\^\\(.*?\\)|[\\w\\.\\^]+|\\(?\\([^\\(\\)]+\\)\\)?))', 'g')
const str = `(sdf^sdf*(-sd.f*-(23^3s)))*sdf
-(2.32^23)*-(df.df^78)+dfd(sfsf)
-df.d(sfs.f^sdf+323)/-13+sfdfsdf
(dfd^23sdf)-(234^dfd)
(dfd^23sdf)-(2.34^d.fd)*-(x-3)`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}