# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\b(?!(?:cookieToKeep1|cookieToKeep2)=)([^;=]+=[^;]*(?:; *|$))//mg;t' <<< "someCookie=someValue; anotherCookie=yada61; cookieToKeep1=myValue; cookieToKeep2=myValue2; lastCookie=yada1"